注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

享受编码

    的乐趣

 
 
 

日志

 
 

新编Eclipse J2ME开发环境设置 (基于eclipse)  

2010-01-10 09:43:04|  分类: Java |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

开发环境需要JDK 、Eclipse(Java IDE)、Eclipseme(Ecilpse的J2ME插件)、WTK(J2ME开发包)。

 

到他们:

JDK   JDK需要1.4.2 ,如果你不用这个版本的,放到手机里会出现一些奇怪的问题。http://java.sun.com/j2se/1.4.2/download.html

Eclipse     http://www.eclipse.org/downloads/ (如果你习惯于中文开发,也可以在这里下到中文包NLpack1-eclipse-SDK-3.2-win32.zip )

Eclipseme   http://sourceforge.net/project/showfiles.php?group_id=86829 (最新版本为 1.5.5)

WTK   在这里我们使用2.2版本的,里可以在这里选择英文和简体中文的版本下载http://java.sun.com/products/sjwtoolkit/download-2_2.html

 

 

    先安装JDK,这个其他地方也讲的很多了,这里就略掉。我们进行到下一步,安装Eclipse,

Eclipse 的安装非常简单,就是直接解压到你需要的地方就可以了。如果你需要使用中文包

的话,还要把NLpack1-eclipse-SDK-3.2-win32.zip解压到Eclipse的安装目录,直接覆就可以了,但要注意,在安装语言包前不要运行Eclipse,不然你安装后不会看到你需要的结果

这时你就可以运行Eclipse,直接点击Eclipse.exe就可以了,在启动过程中会让你选择工作目录,你将其设置到你的工作目录既可,如果你不是经常调换工作目录就可以选择下方的下次不提示既可。如果不能运行Eclipse请先检查你的JDK的安装是否正确。

  

   接下来我们来安装Eclipseme这个j2me的插件,这个插件的安装就不是直接解压了,需要在Eclipse中操作安装,下面时安装步骤:

   EclipseME1.5的下载地址:
   http://jaist.dl.sourceforge.net/sourceforge/eclipseme/eclipseme.feature_1.5.0_site.zip            EclipseME1.5目前只有英文版。将下载下来的EclipseME1.5压缩包解压,解压后会有两个文件夹features和plugins。将两个文件夹内的内容分别拷贝到Eclipse安装目录下的features和plugins目录下。这时启动 Eclipse。

   

  接下来我们先放一下Eclipse,来安装WTK,WTK按照安装向导一路下一步安装就可以了。

 

  

  在WTK安装好后我们就来设置Eclipse,先选择 菜单-窗口-首选项,弹出设置对话框,选择J2ME - Device Management,来设置使用的模拟器,点击旁边的导入会提示你一个导入设备的对话框选择到你的WTK所在的目录,然后点击Refresh,获取到模拟器,这时你可以看到WTK的几种模拟器。然后点击完成,导入这些设备。这时已经可以进行J2ME的开发了,为了方便你的使用.

 

在这里我再介绍一点,在使用中的必要设置。

1.  J2ME 的javadoc的设置,如果你希望在编辑环境中有API的提示,你可以在刚才设置模拟器的地方

 


,选择你要设置javadoc的模拟器,然后选择edit,然后再在选项卡中点击Libraries,选中你要设置的API的项目,点击后面的javadoc就可以进行设置。

2.  J2ME的调试是需要重新设置的,不然你的模拟器是没法启动的,在首选项中,选择java-调试

 


,将暂挂执行里面的选项全部去掉,然后将通讯中调试器超时调整成为20000毫秒。这样可以顺利启动调试器进行J2ME的调试。

3.  设置构建路径,这个是根据个人喜好来的,如果你希望的资源和源代码能分开的话最好将这个选项选择为文件夹

 


4.  混淆器的设置,在J2ME的打包过程中会使用到Eclipse的混淆器,

我们没有设置混淆器,不能使用“Create Obfuscated Package”。混淆器对减小Jar包大小,防止程序被反编译很有用,因此很有必要在J2ME开发环境中设置混淆器。


这时需要到

http://sourceforge.net/project/showfiles.php?group_id=54750 下载一个叫ProGuard的混淆器,解压后,在混淆器的选项中选择到混淆器的目录


 

  

 

本文来自CSDN博客,转载请标明出处:http://blog.csdn.net/jaylongli/archive/2008/11/27/3389676.aspx

  评论这张
 
阅读(453)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018